[rabbitmq-discuss] Acknowledging for the deletion of the message
simon at rabbitmq.com
Wed Oct 13 11:18:00 BST 2010
On 13/10/10 11:13, Irmo Manie wrote:
> Shouldn't that parameter be renamed anyway? In my opinion negative
> parameter names always cause to many confusions. 'autoAck' or something
> similar would be much better I reckon.
Maybe. It's part of the spec though. I'd be a bit reluctant to rename it
in the clients since I think clients should use the same language as the
spec, so we're all speaking the same language. And I guess maybe they
named it like that in the spec since noAck=true is actually the
non-typical way to do things, and they wanted booleans to default to
false. At a guess.
Staff Engineer, RabbitMQ
SpringSource, a division of VMware
More information about the rabbitmq-discuss