[rabbitmq-discuss] Consumer stop to receive messages but continue listening queue problem.

Gustavo Aquino aquino.gustavo at gmail.com
Mon Mar 22 19:25:41 GMT 2010

I think that I discovery a pattern for this problem, and now I can reproduce
it all the time.

This is the steps.

1- Start RabbitMQ
2- Start 8 consumers in concurrent mode (8 consumers at same time).
3- Start producer
4- Fating queue with ~3000 messages per second having ~400bytes
5- When queue have ~170.000 stop consumers and producer
6- Start consumers in concurrent mode(8 consumers at same time)

After that, consumers are connected to Rabbit, but if you take a look about
queue consumers, we have only 3 or 4 consumers... all others are waiting
something but don't consume nothing.

I do some tests follow.

1- Stop others 5 consumers that are listening nothing, and start one by
one... and the same status happen again, this other don't get any message
from rabbitmq until the 3 started before continuing running and getting

2- Wait queue size go to 0 and stop all consumers and start again, now all
work fine again and all 8 consumers getting messages from Rabbit.

I'm very concerned about this... It show me that I can plug more consumers
to help process in a pick, anybody here get something like that report ?


If I reproduce this same test with a queue size minor than 170.000 all works
fine, the problem only happen with queue have more than 170.000.


On Sat, Mar 13, 2010 at 9:45 AM, Gustavo Aquino <aquino.gustavo at gmail.com>wrote:

> Hi David,
> Thanks, but i'm running a ppc machine this package doesn't work, last night
> I compiled Erlang in this environment and it's works very fine.
> To compile we just need to download the right ncourses-dev-version that
> Erlang need.
> Regards.
> On Sat, Mar 13, 2010 at 9:07 AM, David Wragg <david.wragg at lshift.net>wrote:
>> Gustavo Aquino <aquino.gustavo at gmail.com> writes:
>> > This is the point, I think that we will be the first in this
>> environment, I
>> > tried to found some experiences in Internet but don't found nothing. I'm
>> > using Erlang R12 yes I know it's very old, but RH have only this version
>> > compiled for ppc, I'm trying to install R13B but having some compiling
>> > problems with ncourses, but It's other e-mail :).
>> Have you tried rebuilding a recent Fedora erlang SRPM on RHEL?  That
>> approach often works for getting recent packages running on RHEL, and
>> should be as simple as:
>> rpmbuild --rebuild
>> http://mirrors.kernel.org/fedora/releases/12/Everything/source/SRPMS/erlang-R13B-01.2.fc12.src.rpm
>> This will do things like checking that you have suitable versions of
>> all the necessary packages installed for the build, including ncurses.
>> David
>> --
>>  [][][] David Wragg       | mail: david.wragg at lshift.net
>>   [][] Senior Developer  | tel: +44 (0)20 7729 7060
>>  []  [] LShift Ltd        | web: www.lshift.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20100322/1d6c8fc1/attachment.htm 

More information about the rabbitmq-discuss mailing list