[rabbitmq-discuss] RabbitMQ and Qpid Java Client

Carl Trieloff cctrieloff at redhat.com
Tue Mar 9 15:03:42 GMT 2010


It would be best to just post the issue to the users at qpid.apache.org
and one of the Java guys can help Stefan directly. It is controlled
with the connection string is my understanding.

Carl.


On 03/09/2010 09:54 AM, Alexis Richardson wrote:
> Thanks Carl,
>
> I was not sure exactly how to set up Qpid's Java client to speak the
> different protocol versions.  Is there anything that Stefan would need
> to know, based on his original question?
>
> Cheers
>
> alexis
>
>
> On Tue, Mar 9, 2010 at 2:52 PM, Carl Trieloff<cctrieloff at redhat.com>  wrote:
>    
>> On 03/09/2010 09:48 AM, Carl Trieloff wrote:
>>      
>>> On 03/09/2010 09:43 AM, Alexis Richardson wrote:
>>>
>>>        
>>>> Stefan,
>>>>
>>>> Your assumption is correct.  The Qpid Java client that speaks AMQP
>>>> 0-10 will not work with the RabbitMQ broker which speaks 0-8.
>>>>
>>>>
>>>>          
>>> Actually the Qpid Java client can speak 0-8, 0-9, (0-91 in the new
>>> 0-6 release) and 0-10 of AMQP.
>>>
>>>
>>>        
>>
>> Here is the link for 0.5 http://qpid.apache.org/amqp-compatibility.html
>>
>> In 0.6, the Java client also support 0-9-1 and the Java broker also
>> supports 0-10.
>>
>> regards
>> Carl.
>>
>> _______________________________________________
>> rabbitmq-discuss mailing list
>> rabbitmq-discuss at lists.rabbitmq.com
>> http://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
>>
>>      





More information about the rabbitmq-discuss mailing list