[rabbitmq-discuss] configure: error: could not find AMQP spec file at "'/codegen/amqp-0.9.1.json'"

David Wragg david at rabbitmq.com
Wed Jul 14 17:22:58 BST 2010

Hi Rauan,

Rauan Maemirov <rauan at maemirov.com> writes:
> I'm getting this error while trying to install rabbitmq-c... yes, i've
> already seen this thread at
> http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/2010-April/007011.html,
> but it doesn't solve this problem. How can I set codegen path in configure?
> (i tried many ways, but none of them worked for me)

I'm trying to reproduce your problem, but I think I'm going to need more

If I do

  $ cd /tmp
  $ rm -rf rabbitmq-c rabbitmq-codegen
  $ hg clone http://hg.rabbitmq.com/rabbitmq-codegen/
  $ hg clone http://hg.rabbitmq.com/rabbitmq-c/
  $ cd rabbitmq-c
  $ autoreconf -i
  $ ./configure
  $ make

everything builds fine.  Could you give a similar recipe to reproduce
your error?

I happen to be working on a Fedora machine.  What operating system are
you on?


David Wragg
Staff Engineer, RabbitMQ
SpringSource, a division of VMware

More information about the rabbitmq-discuss mailing list