[rabbitmq-discuss] UPDATE: Re: Running RabbitMQ as a Windows Service - Having some problems

Eran Sandler eran.sandler at gmail.com
Mon Sep 1 15:33:53 BST 2008

I've tried running both on the same user account and it still didn't 
manage to access it.

What do I pass to the -setcookie <cookie> parameter (so I'll try that as 


Matthias Radestock wrote:

> Eran,
> Eran Sandler wrote:
>> When I run "rabbitmqctl status" I get the following error in the log:
>> ** Connection attempt from disallowed node rabbitmqctl at yeddaweb7 **
>> Can it be a permissions problem of some kind? RabbitMQ's process runs 
>> under the Local system account while the process of rabbitmqctl runs 
>> under a local user.
> Erlang uses cookies to control which nodes are allowed to connect to 
> each other. The cookie file lives in the user's home directory in the 
> file .erlang.cookie.
> Since in your setup the rabbitmqctl command is run by a different user 
> than the RabbitMQ server, you need to either make the contents of the 
> .erlang.cookie files the same or use the -setcookie <cookie> parameter 
> to erl.exe to set the cookie explicitly.
> Regards,
> Matthias.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20080901/825da741/attachment.htm 

More information about the rabbitmq-discuss mailing list