[rabbitmq-discuss] Rabbitmqctl issues

Edwin Fine rabbitmq-discuss_efine at usa.net
Mon Oct 6 23:18:19 BST 2008

> This is what I had tried originally. In fact thats what the default init.d
> script that is packaged with rabbitmq-server in debian looks like. However,
> it never worked when trying to stop the rabbitmq server or add a new user. I
> would always receive a bad_node error.

If you search this forum, you will see that I sent out a step-by-step guide
to installing RabbitMQ. I have used this to install RabbitMQ successfully on
both Ubuntu and OpenSuSE on multiple systems. If you would consider
re-installing from scratch, following those instructions to the letter (it
is important not to skip any steps), maybe this would help. Sometimes things
just get so messed up that only a clean install will fix them. For example,
if you start something as root when you shouldn't, and some file somewhere
gets created with root as owner, and you get an inexplicable error when you
start up as a different user, it can be hell to try to find that file
especially when you didn't even know it existed :) Hmmm... actually, you can
do an lsof and see which files rabbit is using. You may be surprised.

I've tried both sh and bash.

Ok, it was worth a try.

> Also, with this init script, I'd like to set my MNESIA_BASE path to
> something else which doesn't quite work either.

That's weird; I have changed the MNESIA_BASE path just fine. Be aware,
though, that you can't just copy the files there, you need to start with an
empty directory and let Rabbit recreate the databases. Then you have to add
the users and permissions and so on.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20081006/116c07ff/attachment.htm 

More information about the rabbitmq-discuss mailing list