[rabbitmq-discuss] URGENT: Run-Tests failing...please help

Lynton Grice lynton.grice at netweaverguru.com
Sun May 4 15:29:57 BST 2008

Thanks for the help Matthias....

I ran it now and yes, there are a couple errors but also lots of OK messages
when the tests run...

Thanks again


-----Original Message-----
From: Matthias Radestock [mailto:matthias at lshift.net] 
Sent: 04 May 2008 04:11 PM
To: Lynton Grice
Cc: rabbitmq-discuss at lists.rabbitmq.com
Subject: Re: [rabbitmq-discuss] URGENT: Run-Tests failing...please help

Lynton Grice wrote:
> I run windows.....how can I do what you said: 
> svn co http://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid/python 
> qpid_testsuite
> In windows?

You'll need a subversion client. The above checks out the latest qpid 
test suite from qpid's subversion trunk.

Anyway, I found the problem. The test suite that ships with qpid-1.0-M2 
sets the vhost to "localhost" (well, the host name of the broker you are 
connecting to, actually) instead of "/". Just change client.py:46 to read
   self.vhost = "/"
and the tests should run. You will see a few errors due to the fact that 
the M2 test suite does not support exclusion patterns. Other than that 
things work fine.


More information about the rabbitmq-discuss mailing list