[rabbitmq-discuss] URGENT: Run-Tests failing...please help

Lynton Grice lynton.grice at netweaverguru.com
Sun May 4 14:14:50 BST 2008

Hi Matthias,


Thanks for the feedback......I tried exactly what you said and it is still
going into error.


I downloaded the latest spec - amqp.0-8.xml - and put it into the same
directory at the "run-tests" file....and also copied it into the specs
folder in the standard QPID installation....


You can find the command attached....


I also added the exclusions like you said to the rabbit_failing.txt ...


Any other ideas you can think of that I may be doing wrong?


Perhaps tell me what versions you guys are running?


Thanks for the help thus far ;-)






-----Original Message-----
From: Matthias Radestock [mailto:matthias at lshift.net] 
Sent: 04 May 2008 01:01 PM
To: Lynton Grice
Cc: rabbitmq-discuss at lists.rabbitmq.com
Subject: Re: [rabbitmq-discuss] URGENT: Run-Tests failing...please help




Lynton Grice wrote:

> Then I go to the command line, for example 

> D:\Python24\Lib\site-packages\qpid-1.0-incubating-M2-python-src\python 

> and run python run-tests


> I get many many errors...I also tried different variations of python 

> run-tests -? to try different SPEC files etc..still errors...here is the 

> stack trace...


You must tell the tests to use the official amqp0-8.xml from 

https://jira.amqp.org/confluence/display/AMQP/Download, *not* the spec 

that ships with qpid. In our test suite we run the tests with

   python run-tests -v -s <path-to-official-spec> -I rabbit_failing.txt


where rabbit_failing.txt contains a list of exclusions for tests that 

need to skipped because they either depend on a different spec, test 

features not implemented in rabbit, or make assumptions about the 

implementation. Currently these are:















>     try:

>       # here we depend on all nowait fields being named nowait

> *_      f = method.fields.byname["nowait"]_*

>       nowait = args[method.fields.index(f)]

>     except KeyError:

>       nowait = False


> It dies on the above code *_f = method.fields.byname["nowait"]..._*


What error does the above return?




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20080504/7b70d0ae/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: error.png
Type: image/png
Size: 8285 bytes
Desc: not available
Url : http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20080504/7b70d0ae/attachment.png 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: result.png
Type: image/png
Size: 5165 bytes
Desc: not available
Url : http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20080504/7b70d0ae/attachment-0001.png 

More information about the rabbitmq-discuss mailing list