[rabbitmq-discuss] RabbitMQ 1.4 stomp plugin support?

Tony Garnock-Jones tonyg at lshift.net
Wed Dec 17 10:04:24 GMT 2008

Hi Adam,

(I've taken the liberty of CCing the rabbitmq-discuss mailing list, as
I'm going to be out of the country for a few weeks and will not be
constantly connected.)

2008/12/16 Adam Chase <ac5p at yahoo.com>:
> I was wondering if this is compatible with version 1.4.
> If not, do you know where I can download 1.3 of rabbitmq?
> I tried it and it all compiles fine, but no message and nothing listening on
> port 61613

It runs fine with version 1.4 of RabbitMQ. I have been running it over
the last few days mainly against the tip of the default branch of our
Mercurial repository, but having just tried the 1.4 version, it works
OK too.

Both of the following result for me in running, functioning
STOMP-enabled RabbitMQ servers:

1. Tip of default branch (i.e. very close to 1.5.0)

hg clone http://hg.rabbitmq.com/rabbitmq-codegen
hg clone http://hg.rabbitmq.com/rabbitmq-server
hg clone http://hg.rabbitmq.com/rabbitmq-stomp
make -C rabbitmq-server
make -C rabbitmq-stomp run

2. Version 1.4.0 (retrieved from mercurial)

hg clone -r rabbitmq_v1_4_0 http://hg.rabbitmq.com/rabbitmq-codegen
hg clone -r rabbitmq_v1_4_0 http://hg.rabbitmq.com/rabbitmq-server
hg clone -r rabbitmq_v1_4_0 http://hg.rabbitmq.com/rabbitmq-stomp
make -C rabbitmq-server
make -C rabbitmq-stomp run

If these don't work, you could try sending us a transcript of a
session in which you download and build the components, so we can see
what's going wrong. (If you haven't used it before, try script(1) (man


More information about the rabbitmq-discuss mailing list